Inscription / Connexion Nouveau Sujet
Niveau seconde
Partager :

Algorithme

Posté par
justine2194
07-11-09 à 15:19


bonjour,

J'ai un exercice a faire mais j'ai du mal a comprendre une partie de la consigne.
Voici l'algorithme :

Entrées
Saisir n : entier naturel superieur à 2
Saisir une liste de reels : X1, X2,....Xn

Traitement
Pour i de 1 jusqu'a n-1
  j prend la valeur de n
    Tant que i<j
      Si Xj<Xi alors
        Echanger Xj et Xj-i dans la liste
      FinSi
      j prend la valeur j-1
     FinTantque
Fin pour

Sortie
Afficher la liste X1, X2,....Xn


Les questions qui me sont poser a partir de l'algorithme sont :

a) Faire fonctionner cet algorithme : reproduire et completer le tableau suivant afin de suivre l'evolution des variables. On prend n=4 et la liste : 7361

i           1     1    ...
j           4     3    ...
Liste     7316   7136  ...

b)Appliquer l'algorithme a d'autres listes et indiquer le rôle de l'algorithme


Voila. Je comprend le principe de l'algorithme mais je ne comprend pas ce qui est en gras, c'est-à dire tout ce qui concerne les listes.

Ne comprenant pas le principe de liste, j'ai du mal a faire mon exercice
Auparavant, merci de votre aide !

Ju'

Posté par
-Tonio-
re : Algorithme 07-11-09 à 19:23

Bonsoir

Une liste en algorithme est un suite de nombres n'ayant pas forcément un ordre logique. Quelques indications pour l'utilisation de la calculatrice :

--> pour saisir la liste 7,3,6,1 il faut écrire la ligne suivante :
:{7,3,6,1}L1
L1 est le nom de la liste, tu devrais l'avoir au-dessus du 1 (tu l'écris en faisant 2nd > 1), sinon dans le menu List.

--> échanger Xj et Xj-i n'est pas évident : je te propose de faire comme ça (il y a peut-être d'autres méthodes) :
:L1(J)A
:L1(J-I)B
:BL1(J)
:AL1(J-I)

--> pour afficher la liste c'est disp L1 ou L1 tout court. Pour pouvoir facilement compléter le tableau, je te conseille de mettre la commande en ajoutant une pause (commande Pause) juste avant le FinSi.

Par contre, je ne vois pas très bien le rôle de cette algorithme, à part celui de coder une suite de chiffres (donc un rôle de cryptage ?).

@+

Posté par
Bast05
re: Algorithme 24-05-10 à 10:14

Bonjour,
j'ai cet exercice dans mon DM pour demain...
Je sais que cet algorithme est un algorithme de tri qui range les nombres de la liste dans un ordre croissant.

Mais j'ai de gros problèmes pour le programmer sur ma calculatrice ( TI 82-stats ). Et je ne comprend pas tres bien le tableau

En esperant un réponse en ce lundi ferié, merci d'avance.


PS: je viens de m'inscrire, escusez-moi pour mes quelques transgressions aux regles, s'il y en a...



Vous devez être membre accéder à ce service...

Pas encore inscrit ?

1 compte par personne, multi-compte interdit !

Ou identifiez-vous :


Rester sur la page

Inscription gratuite

Fiches en rapport

parmi 1677 fiches de maths

Désolé, votre version d'Internet Explorer est plus que périmée ! Merci de le mettre à jour ou de télécharger Firefox ou Google Chrome pour utiliser le site. Votre ordinateur vous remerciera !