Inscription / Connexion Nouveau Sujet
Niveau seconde
Partager :

Fonction et algorithme

Posté par
Meikotaku
04-03-19 à 10:26

Rebonjour ou bonjour, j'espère que vous allez tous et toutes très bien. J'aurai besoin de votre aide pour un exercice s'il vous plaît. Merci d'avance pour ceux qui m'aideront et j'espère que ça aidera des end également, voici l'énoncé :

La fonction f est définie sur par F(x)=x²-10x+22
On considère A et k des nombres entiers.
On donne ci-dessous un algorithme.
Pour k allant de 0 à 5
A <- k²-10k+22
Si A >0
Alors afficher k
In SI
In Pour

1) quelle sont les valeurs affichées par l'algorithme ?
2) Quel sont le rôle de cet algorithme ?

J'ai déjà essayé de faire le calcul avec 1,2,3,4 et 5 mais les résultats n'ont aucuns liens spécifiques. :/

Posté par
sanantonio312
re : Fonction et algorithme 04-03-19 à 10:28

Bonjour,
Que trouves-tu pour A pour chaque valeur de k? (0, 1, 2, 3, 4 et 5)

Posté par
Meikotaku
re : Fonction et algorithme 04-03-19 à 12:47

Pour 1 : 14
Pour 2 : 6
Pour 3 : 1
Pour 4 : 2
Pour 5 : 3

C'est normal ?

Posté par
sanantonio312
re : Fonction et algorithme 04-03-19 à 12:52

Pour 1 : 14 Non
Pour 2 : 6 Oui
Pour 3 : 1 Oui
Pour 4 : 2 Non
Pour 5 : 3 Non
Fais voir le détail de tes calculs...
Il manque f(0)

Posté par
Meikotaku
re : Fonction et algorithme 04-03-19 à 12:58

Ah oui pour 0 je trouve 22. Pour faire ce calcul la par exemple pour 1.
Je fais 1 au carré, ce qui donne 1 puis je multiplie 10 par x qui est 1 donc ça donne 10. Il reste -9+22 = 13 !
Oui en effet, il y a un problème de calcul, je vais rectifier tout ça alors puis je reviens, merci. Je suis tellement étourdie.

Posté par
Meikotaku
re : Fonction et algorithme 04-03-19 à 13:02

Du coup :
Pour 0 : 22
Pour 1 : 13
Pour 2 : 6
Pour 3 : 1
Pour : -2
Pour : -3
Mais je ne vois pas le rapport entre ces resultats .

Posté par
sanantonio312
re : Fonction et algorithme 04-03-19 à 13:09

Les f(k) sont justes, mais tu ne t'es jamais posé la question: "Si A >0"

Posté par
Meikotaku
re : Fonction et algorithme 04-03-19 à 13:15

Pouvez approfondir s'il vous plaît, je ne comprends pas vraiment ou vous voulez en venir, excusez moi

Posté par
mathafou Moderateur
re : Fonction et algorithme 04-03-19 à 15:57

Bonjour,

peut être comme dans l'autre exo que tu n'as pas vu que l'algorithme proposé était


Pour k allant de 0 à 5
A <- k²-10k+22
Si A >0
Alors afficher k
Fin SI
Fin Pour

et pas compris que dans une boucle "pour" on doit répéter tout ce qu'il y a entre le "Pour" et le "Fin Pour" ?

(et puis recopier correctement Fin SI et Fin Pour)

Posté par
Meikotaku
re : Fonction et algorithme 05-03-19 à 04:31

Bonjour, j'ai beau essayer mais je n'arrive pas à le faire, vous pouvez me montrer comment faire ? J'ai oublié de préciser que c'est la première fois que je fais ça et qu'on l'avait jamais fais en cours..

Posté par
mathafou Moderateur
re : Fonction et algorithme 05-03-19 à 09:57

tu ne sais pas pour chacun des calculs des f(k) que tu as fait te poser la question si ce résultat est >0 ou pas ??
faut pas pousser !



Vous devez être membre accéder à ce service...

Pas encore inscrit ?

1 compte par personne, multi-compte interdit !

Ou identifiez-vous :


Rester sur la page

Inscription gratuite

Fiches en rapport

parmi 1489 fiches de maths

Désolé, votre version d'Internet Explorer est plus que périmée ! Merci de le mettre à jour ou de télécharger Firefox ou Google Chrome pour utiliser le site. Votre ordinateur vous remerciera !