Inscription / Connexion Nouveau Sujet
Niveau seconde
Partager :

programe sur algobox

Posté par
elp2903
17-01-18 à 11:59

bonjour j ai un devoir maison a faire mais j ai été absente toute la sécance et je n ais absolument rien compris...  pouvez vous m'aider ?
Enoncé :
donner la liste des diviseurs d'un nombre entier n donné.

j ai un peut commencé mais ça ne marche pas... voici ce que j ai mis :
fonction utilisables
variables
n est du type nombre
k est du type nombre
diviseur est du type chaine

debut algo
n prend la valeur 48
lire n
k prend la valeur 2
diviseur prend la valeur 1
tant que (k<=n) faire
debut tant que
si (n%k==0) alors
debut si
diviseur prend la valeur diviseur +"1;48"+k
fin si
k prend la valeur k+1
fin tant que
diviseur prend la valeur diviseur +"0}48"
afficher diviseur
fin algo

j ai trouvé ca sur internet... mais ca ne marche pas...
merci d'avance

Posté par
carita
re : programe sur algobox 17-01-18 à 12:19

bonjour

faut pas tout gober sur internet...
que comprends-tu de cet algorithme ? que fait-il ?

Posté par
Glapion Moderateur
re : programe sur algobox 17-01-18 à 12:20

Bonjour
n prend la valeur 48 inutile si l'instruction d'après est lire n

diviseur +"1;48"+k pourquoi 1;48
diviseur prend la valeur diviseur +" "+k serait plus cohérent

Sinon à part ça, il faut respecter la syntaxe Algobox :


VARIABLES
	n EST_DU_TYPE NOMBRE
	k EST_DU_TYPE NOMBRE
	diviseur EST_DU_TYPE CHAINE
DEBUT_ALGORITHME
	LIRE n
	k PREND_LA_VALEUR 2
	diviseur PREND_LA_VALEUR 1
	TANT_QUE (k<=n) FAIRE
		DEBUT_TANT_QUE
		SI (n%k==0) ALORS
			DEBUT_SI
			diviseur PREND_LA_VALEUR diviseur+" "+k
			FIN_SI
		k PREND_LA_VALEUR k+1
		FIN_TANT_QUE
	diviseur PREND_LA_VALEUR diviseur+" "
	AFFICHER diviseur
FIN_ALGORITHME


(tu peux le copier/coller dans algobox en mode éditeur de texte, ou bien directement en ligne dans proglab )


Posté par
mathafou Moderateur
re : programe sur algobox 17-01-18 à 12:28

Bonjour,

à quoi sert la ligne
diviseur PREND_LA_VALEUR diviseur+" "
finale ?

Posté par
Glapion Moderateur
re : programe sur algobox 17-01-18 à 12:33

la dernière ligne ? effectivement, elle ajoute un blanc à la fin, ce qui n'a pas grand intérêt.
j'ai mécaniquement gardé l'instruction mais on peut l'enlever.

Posté par
elp2903
re : programe sur algobox 17-01-18 à 14:38

Merci
Mais alors du coup je ne met rien entre les "  " ?

Posté par
mathafou Moderateur
re : programe sur algobox 17-01-18 à 14:53

une fois qu'il a terminé de mettre la liste des diviseurs, que pourrait bien avoir le programme à dire de plus ?

ici il dit un espace après cette liste
vachement utile !!
tu peux même retirer complètement cette instruction qui ne sert à rien...

Posté par
elp2903
re : programe sur algobox 17-01-18 à 15:10

Ah d accord Merci beaucoup



Vous devez être membre accéder à ce service...

Pas encore inscrit ?

1 compte par personne, multi-compte interdit !

Ou identifiez-vous :


Rester sur la page

Inscription gratuite

Fiches en rapport

parmi 1567 fiches de maths

Désolé, votre version d'Internet Explorer est plus que périmée ! Merci de le mettre à jour ou de télécharger Firefox ou Google Chrome pour utiliser le site. Votre ordinateur vous remerciera !