Inscription / Connexion Nouveau Sujet
Niveau seconde
Partager :

simuler Le lancer d'un dé Algorithme

Posté par
ynskp13j
20-01-18 à 14:05

Salut  , Svp je ne comprends pas comment faire cet algorithme pouvez vous m'aider ❤❤
Ecrire un algorithme permettant de simuler le lancer d'un dé cubique une fois, 100 fois et 600 fois en donnant le nombre de 6 obtenus
Or quand je fais l'algorithme pour 100 fois ou meme 6 fois il me disent depassement de capacite de boucle svp aider moi merci d'avance

Posté par
Glapion Moderateur
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:14

Bonjour, tu devrais nous montrer ton algorithme alors, on te dira ce qui ne va pas.

Posté par
ynskp13j
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:19

d'accord je vais l'envoyer tout de suite

Posté par
ynskp13j
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:24

F est du type nombre
N est du type nombre
S est du type nombre
lire N
S prend la valeur 0
F prend la valeur 0
Pour F allant de 1 a N
debut pour F prend la valeur floor(6*random())+1
si F==6
S prend la valeur S+1
fin si
fin pour
Afficher S

Posté par
ynskp13j
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:26

bonjour  glapion ,
Je voudrais pouvoir le tester Pour 1 fois 100 fois et 600 fois d'ou en meme temps en comptant le nombre de fois qu'apparait 6

Posté par
Glapion Moderateur
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:43

Ton erreur vient que tu utilises F comme variable de boucle mais aussi pour stocker le résultat aléatoire du tirage. Utilise deux variables distinctes.

Respecte aussi la syntaxe algobox :


VARIABLES
	F EST_DU_TYPE NOMBRE
	N EST_DU_TYPE NOMBRE
	S EST_DU_TYPE NOMBRE
	I EST_DU_TYPE NOMBRE
DEBUT_ALGORITHME
	LIRE N
	S PREND_LA_VALEUR 0
	POUR I ALLANT_DE 1 A N
		DEBUT_POUR
		F PREND_LA_VALEUR ALGOBOX_ALEA_ENT(1,6)
		SI (F==6) ALORS
			DEBUT_SI
			S PREND_LA_VALEUR S+1
			FIN_SI
		FIN_POUR
	AFFICHER S
FIN_ALGORITHME


(tu peux le copier/coller dans algobox en mode éditeur de texte, ou bien directement en ligne dans proglab )

Posté par
ynskp13j
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:54

Ah daccord j'ai compris maintenant donc on a pas changé grand chose merci pour ton aide Glapion

Posté par
Glapion Moderateur
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:58

Citation :
on a pas changé grand chose


on a changé quelque chose de capital !!

Posté par
ynskp13j
re : simuler Le lancer d'un dé Algorithme 20-01-18 à 14:59

Oui je blaguais



Vous devez être membre accéder à ce service...

Pas encore inscrit ?

1 compte par personne, multi-compte interdit !

Ou identifiez-vous :


Rester sur la page

Inscription gratuite

Fiches en rapport

parmi 1567 fiches de maths

Désolé, votre version d'Internet Explorer est plus que périmée ! Merci de le mettre à jour ou de télécharger Firefox ou Google Chrome pour utiliser le site. Votre ordinateur vous remerciera !