Inscription / Connexion Nouveau Sujet
Niveau seconde
Partager :

une fonction algorithmes

Posté par
lilou281171
27-03-17 à 19:03

algorithmes structures alternatives

1. écrire un algorithme qui permet de calculer les images de la fonction f définie sur R par :
f:(x)=-2x si x inférieur 0
            x carré si x supérieur égal 0

2. compléter alors le tableau de valeurs suivant et tracer Cf dans le repère ci contre

tableau x   -3;-1;0;0.5;1;1.5;2;2.5
              f(x)    6;2;0;0.25;1;2.25;4;6.25

variable
x
début x
si x inférieur 0
début
si
x prend la valeur -2*-3
affiche f(x)
finsi
sinon
x carré supérieur ou égal 0
affiche
fin

Posté par
carita
re : une fonction algorithmes 27-03-17 à 19:11

bonsoir

pour voir si tu as compris la définition de la fonction,
tu veux bien calculer l'image de -2 ?
l'image de 3 ?

Posté par
carita
re : une fonction algorithmes 27-03-17 à 19:19

ce qui est en rouge ne va pas

variable
x
début x  ----- que veux-tu dire par là ? précise
si x < 0
          début si
          x prend la valeur -2*-3
         affiche f(x)  ---- tu peux ne l'afficher qu'à la fin
         finsi  
        sinon   ------ dans quel cas on est ici ?
                 debut sinon
                  x carré supérieur ou égal 0
                  fin sinon              
affiche quoi ?
fin

Posté par
carita
re : une fonction algorithmes 27-03-17 à 19:20

2) les valeurs du tableau sont exactes

Posté par
lilou281171
re : une fonction algorithmes 27-03-17 à 19:26

bonjour carita

variable x pour moi c'est -3
si x<0
début si
x prend la valeur -2*-3
affiche f(x) 6
finsi
sinon
si x
début x carré supérieur ou égal 0
fin sinon
affiche
g(x)
fin

Posté par
carita
re : une fonction algorithmes 27-03-17 à 19:42

apparemment, il y a qq chose que tu n'as pas bien compris :
l'algorithme, on doit le rédiger pour qu'il soit capable de calculer n'importe quelle image par la fonction f.
on ne doit pas spécifier de valeur particulière pour x
x reste "x", variable dont on doit demander la saisie pour que la machine puisse calculer.

pour que ce soit bien clair pour toi,
on peut aussi définir une seconde variable, appelée y par exemple,
qui recevra l'image de x   : donc y, ce sera f(x)

variables
x est du nombre
y est un nombre


variable x pour moi c'est -3  ---- peut-être, mais pour la machine, si tu ne demandes pas de "lire" ou "saisir" x,
elle ne le devinera pas
donc quelle ligne tu écris ?

si x<0  
       début si  
----  donc ici on traite le cas où x  <0
       y prend la valeur -2* ?
       finsi

      sinon    ----    ici on traite le cas où x   0
                 debut sinon
                  y prend la valeur ??
                  fin sinon      
afficher  ??
fin



Vous devez être membre accéder à ce service...

Pas encore inscrit ?

1 compte par personne, multi-compte interdit !

Ou identifiez-vous :


Rester sur la page

Inscription gratuite

Fiches en rapport

parmi 1510 fiches de maths

Désolé, votre version d'Internet Explorer est plus que périmée ! Merci de le mettre à jour ou de télécharger Firefox ou Google Chrome pour utiliser le site. Votre ordinateur vous remerciera !